Translation orders delayed
Incident Report for Phrase
Resolved
This incident has been resolved.
Posted Aug 17, 2021 - 13:49 CEST
Investigating
We're experiencing some issues and delays with submitting translation orders at the moment. We're investigating the problem.
Posted Aug 17, 2021 - 10:04 CEST
This incident affected: Phrase (Ordering).