Upload processing issues
Incident Report for Phrase
Resolved
The issue is resolved, everything is back to normal.
Posted Oct 19, 2021 - 13:30 CEST
Investigating
We're experiencing performance degradation in upload processing, the team is looking into it.
Posted Oct 19, 2021 - 10:55 CEST
This incident affected: Phrase (Translation Center, API).