Connectivity Issues
Incident Report for Phrase
Resolved
This incident has been resolved.
Posted May 03, 2019 - 12:13 CEST
Investigating
We're experiencing connectivity issues. Currently investigating!
Posted May 03, 2019 - 11:52 CEST
This incident affected: Phrase Strings (EU) (Translation center, Bitbucket sync, Email delivery, Ordering, In-context editor, API).