OTA Connectivity issues
Incident Report for Phrase
Resolved
This incident has been resolved.
Posted Oct 25, 2021 - 16:40 CEST
Investigating
We're seeing connectivity issues with Phrase OTA. We're currently investigating!
Posted Oct 25, 2021 - 16:03 CEST
This incident affected: Phrase (OTA).