Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 25, 2026 - 09:00 CEST
Scheduled
Start time: August 25, 2026 @ 09:00 AM CEST End time: August 25, 2026 @ 12:00 AM CEST
Customers affected: Users of Phrase TMS and Phrase Strings that browse to the Phrase Analytics page. Products affected: Phrase TMS - Analytics, Phrase Strings - Analytics.
What will occur during maintenance:
• Users visiting the Analytics page might receive an error message within the page and the content might not load. • Users already on the Analytics page might receive an error message upon refresh of the page and the content might not load.
Why we're doing this:
• We are upgrading the version of an underlying third-party software.
Posted Aug 24, 2026 - 15:24 CEST
This scheduled maintenance affected: Phrase TMS (EU) (Analytics) and Phrase TMS (US) (Analytics).