Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 29, 2026 - 13:00 CEST
Scheduled
Customers affected: Users of the Analytics page in TMS and Strings, and users of the MT Usage page in Phrase Language AI.
Products affected: Phrase Analytics (TMS), Phrase Analytics (Strings), and MT Usage (Phrase Language AI).
What will occur during maintenance: - Users visiting the affected pages might receive an error message and the content might not load. - Users already on the affected pages might receive an error message upon refresh, and the content might not load. - Dashboards and downloads within the affected pages may be temporarily unavailable. - Data refresh within the affected pages may be delayed during the migration window.
Why we're doing this: - We are migrating the underlying backend database to a more robust set of data pipelines to improve reliability and performance.
Posted Jul 27, 2026 - 14:49 CEST
This scheduled maintenance affected: Phrase TMS (EU) (Analytics) and Phrase TMS (US) (Analytics).