We have successfully deduplicated metrics consumption for all blocked organizations. We are continuing work to develop per-organization deduplication tooling to ensure accurate billing cycle data, with the full team scaling these fixes tomorrow morning.
Posted Jul 16, 2026 - 21:04 CEST
Monitoring
We have stopped the progression of the issue and are now working to identify the full scope of impact, including which organizations are affected or blocked. Affected accounts will be prioritized for resolution through a deduplication process, though this will take some time to complete.
Posted Jul 16, 2026 - 19:31 CEST
Identified
We have identified the root cause as instability on a specific broker, which is causing repeated consumer group rebalancing in our Metrics service and leading to duplicate processing of metric updates. This may result in some customers experiencing incorrect consumption calculations or unexpected account blocking. We continue working on a fix.
Posted Jul 16, 2026 - 18:29 CEST
Investigating
We are currently investigating an issue affecting our Metrics service that may result in duplicated metrics consumption for some customers. Our team is actively working to identify the affected components and determine the root cause. We will provide further updates as more information becomes available.
Posted Jul 16, 2026 - 17:47 CEST
This incident affects: Identity management - IDM (EU) and Identity management - IDM (US).