Degraded Performance of Phrase Orchestrator (US) Workflow Engine between January 09, 04:01 PM CEST and January 09, 05:49 PM CEST

Incident Report for Phrase

Resolved

This incident has been resolved.
Posted Jan 09, 2026 - 17:56 CET

Monitoring

We have restored partial functionality; the team is closely monitoring the system while exploring a permanent fix.
Posted Jan 09, 2026 - 17:50 CET

Investigating

Newly published workflows may experience delayed execution. We are actively investigating the issue.
Posted Jan 09, 2026 - 17:17 CET
This incident affected: Phrase Orchestrator (US) (Legacy Workflow Engine).