Degraded Performance of Phrase Analytics (TMS) and Phrase Data since May 4, 2026

Incident Report for Phrase

Monitoring

We have identified and fixed the root cause. Analytics data should be flowing again for most projects starting today (22 May). We are working on re-ingesting the missing data for the period of 4–21 May, and will share progress updates until that's complete.
Posted May 22, 2026 - 13:08 CEST

Update

We are continuing to investigate this issue.
Posted May 21, 2026 - 15:10 CEST

Investigating

We are investigating an issue affecting Phrase Analytics (TMS) and Phrase Data since May 4, 2026.

Customers may see missing or incorrect analytics metrics for some jobs. Specifically:

Processed words may be missing for jobs with Chinese, Japanese, or Korean (CJK) as the source language.

Characters, completed words, confirmed words, and locked words may be missing for jobs across all language combinations.

We are continuing to investigate and will share further updates as soon as possible.
Posted May 21, 2026 - 11:42 CEST
This incident affects: Phrase TMS (EU) (Analytics) and Phrase TMS (US) (Analytics).