Performance Disruption of Phrase TMS CAT Web Editor and Project Management (EU) on January 29, 2026 between 4:56 PM CET and 5:46 PM CET

Incident Report for Phrase

Postmortem

Introduction

On January 29, 2026, between 4:56 PM and 5:46 PM CET, customers using the Phrase TMS UI in the EU region experienced repeated logouts and instability. API access was not affected.

The incident was classified as SEV-1 and was resolved the same day.

Timeline

  • 4:34 PM CET – Deployment of the TMS core application in the EU region started, including a change to session storage.
  • ~5:00 PM CET – Customers began reporting repeated logouts and UI issues.
  • ~5:30 PM CET – The team identified inconsistent session storage configuration across application instances during the rollout.
  • ~5:48 PM CET – Deployment completed across all instances.
  • 5:46 PM CET – Customer impact ended.
  • 6:45 PM CET – Status page incident closed after monitoring confirmed stability.

Root Cause

During a deployment, session storage was migrated to a new caching solution. Not all application instances were updated at the same time.

As a result, different instances were using different session stores. Since requests from the same user can be handled by different instances, some sessions could not be found, leading to repeated logouts in the UI.

API usage was not impacted.

Actions to Prevent Recurrence

  • Treat session storage changes as planned maintenance and communicate them in advance.
  • Apply stricter deployment controls when modifying shared components.
  • Update internal guidelines to classify session storage configuration changes as high-risk.
Posted Feb 23, 2026 - 08:15 CET

Resolved

Affected components are now stable. The incident has been resolved.
Posted Jan 29, 2026 - 18:45 CET

Monitoring

A fix has been deployed and we are monitoring the results.
Posted Jan 29, 2026 - 17:56 CET

Identified

We've identified performance issues in Phrase TMS CAT Web Editor and Project Management. We've identified the root cause and we are working on a fix.
Posted Jan 29, 2026 - 17:51 CET
This incident affected: Phrase TMS (EU) (CAT web editor, Project management).