Degraded Performance of Phrase TMS (EU) on May 27, 2026 starting at 8:33 PM CEST

Incident Report for Phrase

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 28, 2026 - 01:51 CEST

Update

We are continuing to investigate this issue.
Posted May 27, 2026 - 23:30 CEST

Investigating

We are currently investigating delays in some tasks like job creation, QA and analysis.
Posted May 27, 2026 - 22:19 CEST
This incident affects: Phrase TMS (EU) (File processing).