Degraded Performance of all Phrase TMS (EU) components
Incident Report for Phrase
Resolved
This incident has been resolved.
Posted Feb 20, 2024 - 18:31 CET
Update
We are continuing to investigate this issue.
Posted Feb 20, 2024 - 18:18 CET
Investigating
We are experiencing performance issues affecting all Phrase TMS (EU) components. We are currently investigating the issue.
Posted Feb 20, 2024 - 18:16 CET
This incident affected: Phrase TMS (EU) (Analytics, API, CAT web editor, File processing, Machine translation, Project management, Term base, Translation memory).