Service interruptions at Textmaster

Incident Report for Phrase

Resolved

This incident has been resolved.
Posted Feb 04, 2020 - 14:05 CET

Investigating

Ordering translations via Textmaster is currently not possible due to a Textmaster service outage.
Posted Feb 04, 2020 - 08:59 CET
This incident affected: Phrase Strings (EU) (Ordering).