Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 25, 2026 - 10:30 CEST
Scheduled
The affected services that will be unavailable during this time are: Webflow plugin Contentful (1&2) connectors using the Phrase Contentful App Phrase Contentful App
Posted May 19, 2026 - 15:52 CEST
This scheduled maintenance affected: Phrase TMS (EU) (Connectors) and Phrase TMS (US) (Connectors).