Degraded performance of TMS Project Management Component

Incident Report for Phrase

Resolved

The incident has been resolved.
Posted Jul 08, 2026 - 15:55 CEST

Monitoring

The issue has been identified, a fix was implemented and we are monitoring the situation.
Posted Jul 08, 2026 - 15:08 CEST

Investigating

We are getting reports from users about jobs disappearing from projects and we are currently investigating the issue.
Posted Jul 08, 2026 - 14:57 CEST
This incident affected: Phrase TMS (EU) (Project management).