Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 06, 2025 - 09:00 CEST
Update
We will be undergoing scheduled maintenance during this time.
Posted Aug 28, 2025 - 14:04 CEST
Scheduled
Start time: September 6, 2025 @ 09:00 AM CEST / 03:00 AM EST End time: September 6, 2025 @ 10:00 AM CEST / 04:00 AM EST
Customers affected: All Phrase TMS customers of US data center Products affected: All Phrase TMS products in US data center
What will occur during maintenance:
• Phrase TMS won’t be available for a maximum of 30 minutes within this maintenance window. • A maintenance page with HTTP 503 status will be served to indicate planned downtime. • All dependent services and APIs relying on Phrase TMS will be unreachable or degraded.
Why we're doing this:
• We are making a major upgrade of our Project Management database. • This upgrade will increase system performance, stability, and scalability, ensuring readiness for future load and growth.
Posted Aug 28, 2025 - 12:15 CEST
This scheduled maintenance affected: Phrase TMS (US) (Analytics, API, CAT web editor, Connectors, File processing, Machine translation, Project management, Term base, Translation memory).