Performance Disruption of All Phrase TMS (EU) Components between August 06, 2025 07:51 PM CET and August 06, 2025 08:28 PM CET

Incident Report for Phrase

Resolved

The incident has been resolved.
Posted Aug 06, 2025 - 20:42 CEST

Monitoring

The incident has been resolved, we are monitoring the system.
Posted Aug 06, 2025 - 20:33 CEST

Investigating

We are investigating the issue.
Posted Aug 06, 2025 - 20:20 CEST
This incident affected: Phrase TMS (EU) (Analytics, API, CAT web editor, Connectors, File processing, Machine translation, Project management, Term base, Translation memory).