Degraded Performance of Phrase TMS (EU) Term Base Component

Incident Report for Phrase

Resolved

This incident has been resolved.
Posted Dec 09, 2025 - 15:32 CET

Monitoring

A fix has been implemented, and we are monitoring the situation.
Posted Dec 09, 2025 - 13:47 CET

Identified

The issue has been identified, and a fix is currently being implemented.
Posted Dec 09, 2025 - 12:27 CET

Update

Our engineering team is continuing to investigate the performance issues with the term base service. We’ll share another update as soon as more information is available.
Posted Dec 09, 2025 - 10:58 CET

Investigating

Users may experience intermittent performance issues with the term base service, and our engineering team is actively investigating.
Posted Dec 09, 2025 - 09:44 CET
This incident affected: Phrase TMS (EU) (Term base).