The issue has been resolved and performance is stable.
Posted Sep 01, 2026 - 18:23 CEST
Monitoring
A fix has been deployed and we are monitoring the results. Customers might need to clear browser cache and close all opened tabs with TMS if still experiencing problems.
Posted Sep 01, 2026 - 17:34 CEST
Update
We have identified the root cause of the issue. Our team is actively implementing a fix. We will provide further updates as we make progress.
Posted Sep 01, 2026 - 17:00 CEST
Investigating
We are currently investigating an issue causing slowness in the Jobs view within Phrase TMS (EU). Users may experience delayed load times or reduced performance when accessing project management features. Our team is actively working to identify the root cause and restore normal performance as quickly as possible.
Posted Sep 01, 2026 - 16:18 CEST
This incident affected: Phrase TMS (EU) (Project management).