Degraded performance of IDM (US) between 9:40 AM and 13:42 CET
Incident Report for Phrase
Resolved
This incident has been resolved.
Posted Mar 08, 2024 - 15:47 CET
Investigating
Some users at US server might experience issues when accessing Phrase through IDM. Engineers are currently investigating the root cause.
Posted Mar 08, 2024 - 13:42 CET
This incident affected: Identity management - IDM (US).