Delayed processing
Incident Report for Phrase
Resolved
This incident has been resolved.
Posted Oct 04, 2019 - 15:40 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 04, 2019 - 14:21 CEST
Identified
Multiple components are processing events slower than usual. We have identified the problem and working on a solution
Posted Oct 04, 2019 - 13:36 CEST
This incident affected: Translation Center, API, Ordering, and E-Mail Delivery.